I - Arbitrage(判断正环,SPFA算法)

链接:Arbitrage

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No



题意:

共n种货币(不含空格的字符串),m种兑换关系—— a r b,表示1单位货币a可以兑换r单位货币b(单向,只能用a来兑换b),问能否通过这m种兑换关系来套利(即本金增加)?



分析:

该题就是要判断正环,但这里的正环并不是指 环路权和 为正,因为最后结果是需要路权相乘(兑换时,每次乘以汇率),所以正环是指 环路权积 > 1(负环就是路权乘积 < 1)

那么就可以用SPFA算法或BF算法判断,其 数组d[u]的含义 为:从源点到u的最大路权积
(这样设置,若存在正环,最大路权积会一直增大,SPFA算法入队次数/BF算法松弛次数就会超过N-1)

则对应 松弛条件 为:d[u] * G[u][v] > d[v]



以下代码:

#include<iostream>
#include<map>
#include<queue>
#include<climits>
#include<algorithm>
#include<string> 
#include<cstring>
#define LL long long
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=40;
int N,M;
double G[maxn][maxn],d[maxn];
bool inq[maxn];
int cnt[maxn];
map<string,int> m;
bool SPFA(int s)
{
	memset(d,0,sizeof(d));        //这里d初始化为0
	memset(inq,false,sizeof(inq));
	memset(cnt,0,sizeof(cnt));
	queue<int> q;
	d[s]=1;                       //设本金为 1
	q.push(s);
	inq[s]=true;
	cnt[s]++;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		inq[u]=false;
		for(int v=1;v<=N;v++)
		{
			if(G[u][v]!=0&&d[u]*G[u][v]>d[v])
			{
				d[v]=d[u]*G[u][v];
				if(!inq[v])
				{
					q.push(v);
					inq[v]=true;
					cnt[v]++;
					if(cnt[v]>N-1)
						return true;
				}
			}
		}
	}
	return false;
}
int main()
{	
	int kase=0;
	while(cin>>N&&N)
	{
		kase++;
		memset(G,0,sizeof(G));
		for(int i=1;i<=N;i++)
		{	
			string t;
			cin>>t;
			m[t]=i;
		}
		cin>>M;
		for(int i=1;i<=M;i++)
		{
			string a,b;
			double r;
			cin>>a>>r>>b;
			G[m[a]][m[b]]=r;
		}
		if(SPFA(1))
			cout<<"Case "<<kase<<": Yes\n";
		else
			cout<<"Case "<<kase<<": No\n";
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值