1009 Product of Polynomials (25 分) (*)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

我的代码:
 

#include <cstdio>

int main() {
    double a[2110] = {0.0} ,b[2110] = {0.0};
    int e,c0,c1,count = 0; //k为系数,e为指数,count计数不为零的倒数项个数
    double k;
    scanf("%d",&c0);
    for(int i=0; i<c0; i++){
        scanf("%d %lf",&e,&k);
        a[e] = k;
    }
    scanf("%d",&c1);
    for(int i =0; i<c1; i++){
        scanf("%d %lf",&e,&k);
        for(int j = 2000;j>=0;j--){
            if(a[j] != 0.0){
                if(b[j+e] == 0) count++;
//                printf("a[j] = %f, j = %d, ",a[j],j);
//                printf(" X  k =%f, e = %d ==",k,e);
                b[j+e] += a[j]*k;
//                printf("b[j+e] = %f, j+e = %d\n",b[j+e],j+e);
                
            }
        }
    }
    printf("%d ",count);
    for(int j = 2010; j>=0; j--){
        if(b[j] - 0.0 > 0.000001){
            printf("%d %.1f",j,b[j]);
            count--;
            if(count != 0){
                printf(" ");
            }
        }    
    }
    
    return 0;
}

 代码运行的五个测试点里有一个不能通过,现在不清楚是哪里的问题,留待观摩大神的代码后再重做。有朋友知道问题在哪也可以帮我指出来,多谢

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值