CSU-ACM2017暑期训练1-Debug与STL C-Languages-map判重

题目:C-Languages

The Enterprise has encountered a planet that at one point had been inhabited. The only remnant from the prior civilization is a set of texts that was found. Using a small set of keywords found in various different languages, the Enterprise team is trying to determine what type of beings inhabited the planet.

Input

The first line of input will be N (1 ≤ N ≤ 100), the number of different known languages. The next N lines contain, in order, the name of the language, followed by one or more words in that language, separated with spaces. Following that will be a blank line. After that will be a series of lines, each in one language, for which you are to determine the appropriate language. Words consist of uninterrupted strings of upper or lowercase ASCII letters, apostrophes, or hyphens, as do the names of languages. No words will appear in more than one language. No line will be longer than 256 characters. There will be at most 1000 lines of sample text. Every sample text will contain at least one keyword from one of the languages. No sample text will contain keywords from multiple languages. The sample text may contain additional punctuation (commas, periods, exclamation points, semicolons, question marks, and parentheses) and spaces, all of which serve as delimiters separating keywords. Sample text may contain words that are not keywords for any specific language. Keywords should be matched in a case-insensitive manner.

Output

For each line of sample text that follows the blank line separating the defined languages, print a single line that identifies the language with which the sample text is associated.

Sample Input
4
Vulcan throks kilko-srashiv k'etwel
Romulan Tehca uckwazta Uhn Neemasta
Menk e'satta prah ra'sata
Russian sluchilos

Dif-tor heh, Spohkh. I'tah trai k'etwel
Uhn kan'aganna! Tehca zuhn ruga'noktan!
Sample Output
Vulcan
Romulan
  

           题目大意:先给你n串不同语言的字典,然后输入多组字符串,问你这串话是属于什么语言。

          思路:在字符串里面找在字典中出现过的单词,注意题目要求不区分大小写,并且有的标点符号要转化为空格。至于查找这里直接用的map来           映射,自己一开始脑抽写了个嵌套map的,下面给出两种代码,第二种简单些,也是普遍的思路。

            代码1:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <sstream>
#include <algorithm>
#include <map>
using namespace std;

void change(string &si)
{
    for(int j=0;j<si.size();j++)
    {
        if(si[j]==','||si[j]=='.'||si[j]=='!'||si[j]==';'||si[j]=='?'||si[j]=='('||si[j]==')')
            si[j]=' ';
    }
}

void lower(string &si)
{
    for(int j=0;j<si.size();j++)
    {
        if(si[j]>='A'&&si[j]<='Z')
            si[j]+=32;
    }
}

int n;
int flag,lan_num;
int cnt;
string s[111];
string language[111];
string a,b;
map<string,map<string,int>>m;

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        m.clear();
        getchar();
        for(int i=0;i<n;i++)
        {
            getline(cin,s[i]);
            stringstream ss(s[i]);
            ss>>a;
            language[i]=a;
            cnt=0;
            while(ss>>b)
            {
                lower(b);
                if(!m[a].count(b))
                    m[a][b]=++cnt;
            }
        }
        while(getline(cin,a))
        {
            change(a);
            stringstream ss(a);
            flag=0;
            while(!flag&&ss>>b)
            {
                lower(b);
                for(int i=0;i<n;i++)
                {
                    if(m[language[i]].count(b))
                    {
                        lan_num=i;
                        flag=1;
                        break;
                    }
                }
            }
            if(flag)
                cout<<language[lan_num]<<endl;
        }

    }
    return 0;
}

代码2:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <sstream>
#include <algorithm>
#include <map>
using namespace std;

void change(string k)
{
    for(int j=0;j<k.size();j++)
    {
        if(k[j]==','||k[j]=='.'||k[j]=='!'||k[j]==';'||k[j]=='?'||k[j]=='('||k[j]==')')
            k[j]=' ';
    }
}

void low(string k)
{
    for(int j=0;j<k.size();j++)
    {
        if(k[j]>='A'&&k[j]<='Z')
            k[j]+=32;
    }
}

int n;
int flag;
int cnt;
string s;
string a,b;
map<string,string>m;

int main()
{
    scanf("%d",&n);
    getchar();
    for(int i=0;i<n;i++)
    {
        getline(cin,s);
        stringstream ss(s);
        ss>>a;
        while(ss>>b)
        {
            low(b);
            m[b]=a;
        }
    }
    while(getline(cin,a))
    {
        change(a);
        stringstream ss(a);
        flag=0;
        while(!flag&&ss>>b)
        {
            low(b);
            if(m.count(b))
            {
                cout<<m[b]<<endl;
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值