2017CSU暑假集训 Languages

The Enterprise has encountered a planet that at one point had been inhabited. The only remnant from the prior civilization is a set of texts that was found. Using a small set of keywords found in various different languages, the Enterprise team is trying to determine what type of beings inhabited the planet.

Input

The first line of input will be N (1 ≤ N ≤ 100), the number of different known languages. The next N lines contain, in order, the name of the language, followed by one or more words in that language, separated with spaces. Following that will be a blank line. After that will be a series of lines, each in one language, for which you are to determine the appropriate language. Words consist of uninterrupted strings of upper or lowercase ASCII letters, apostrophes, or hyphens, as do the names of languages. No words will appear in more than one language. No line will be longer than 256 characters. There will be at most 1000 lines of sample text. Every sample text will contain at least one keyword from one of the languages. No sample text will contain keywords from multiple languages. The sample text may contain additional punctuation (commas, periods, exclamation points, semicolons, question marks, and parentheses) and spaces, all of which serve as delimiters separating keywords. Sample text may contain words that are not keywords for any specific language. Keywords should be matched in a case-insensitive manner.

Output

For each line of sample text that follows the blank line separating the defined languages, print a single line that identifies the language with which the sample text is associated.

Sample Input
4
Vulcan throks kilko-srashiv k'etwel
Romulan Tehca uckwazta Uhn Neemasta
Menk e'satta prah ra'sata
Russian sluchilos

Dif-tor heh, Spohkh. I'tah trai k'etwel
Uhn kan'aganna! Tehca zuhn ruga'noktan!
Sample Output
Vulcan
Romulan
 
 
题意:
这里就是STL里面的map和stringstream,getline的结合使用,将每一个词的对应键值设置为所属语言
 
 
代码:
#include<map>
#include<cstring>
#include<sstream>
#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
    int t;
    string help1,lei,word;
    map<string,string> m;
    cin>>t;
    getchar();
    for(int i = 0;i<t;i++)
    {
        getline(cin,help1);
        stringstream ss1(help1);
        ss1>>lei;
        while(ss1>>word)
        {
            for(int i = 0;i<word.size();i++)
                if(word[i]>='A'&&word[i]<='Z')
                    word[i]+=32;
            m[word] = lei;
        }
    }
        while(getline(cin,help1))
        {
            for(int i = 0;i<help1.size();i++)
            {
                if(help1[i]==','||help1[i]=='.'||help1[i]=='!'||help1[i]==';'||help1[i]=='?'||help1[i]=='('||help1[i]==')')
                    help1[i] = ' ';
            }
            string s;
            stringstream ss2(help1);
            while(ss2>>s)
            {
                for(int i = 0;i<s.size();i++)
                {
                    if(s[i]>='A'&&s[i]<='Z')
                        s[i]+=32;
                }
                if(m.count(s))
                {
                    cout<<m[s]<<endl;
                    break;
                }
            }

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值