CSU-ACM2017暑假集训2-二分搜索 hdu2141- Can you find it?

题目:

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

           题目大意:问能否在A,B,C,三个数组内各选一个数,使得他们的和为给定的值X

           思路:先选两个数组比如A,B求其各个数相加之和,存到一个数组T中,再枚举数组C的数得到满足X-c=a+b的值,再在T数组中二分查找是否            存在X-c为A,B之和。复杂度O(n*n).

           代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int l,n,m;
int a[555],b[555],c[555];
int a_b[555*555];
int a_b_norep[555*555];
int num_ab;

void init()
{
    int k,t;
    k=t=0;
    for(int i=0;i<l;i++)
        scanf("%d",&a[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&b[i]);
    for(int i=0;i<m;i++)
        scanf("%d",&c[i]);
    for(int i=0;i<l;i++)
    {
        for(int j=0;j<n;j++)
        {
            a_b[k++]=a[i]+b[j];
        }
    }
    sort(a_b,a_b+k);
    a_b_norep[t++]=a_b[0];
    for(int i=1;i<k;i++)
        if(a_b[i]!=a_b[i-1])
            a_b_norep[t++]=a_b[i];
    num_ab=t;
}

int bs(int x)
{
    int l,r,mid;
    l=0;
    r=num_ab;
    while(l<=r)
    {
        mid=(r-l)/2+l;
        if(a_b_norep[mid]==x)
            return 1;
        else if(a_b_norep[mid]<x)
            l=mid+1;
        else
            r=mid-1;
    }
    return 0;
}

int main()
{
    int t,x;
    int no=0;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        init();
        scanf("%d",&t);
        printf("Case %d:\n",++no);
        while(t--)
        {
            int flag=0;
            scanf("%d",&x);
            for(int i=0;i<m;i++)
            {
                if(bs(x-c[i]))
                {
                    flag=1;
                    break;
                }
            }
            if(flag)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值