hdu2141 (二分)

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source

HDU 2007-11 Programming Contest 


题意:分别有a,b,c三个数组,给出一个数,看这个数能不能再a,b,c,里面分别找出一个数求和得到

思路:如果暴力的话肯定会超时;  我们可以将三个数组规划成两个数组,其中一个数组是两个数组的和,并且排序去重。对于每个给出的数,我们依次枚举,然后二分搜索出是否有结果。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N=505;
int len;
int a[N],b[N],c[N],d[N*N];
int find(int x)
{
    int l=0,r=len-1;
    while(l<r)
    {
        int temp=(l+r)/2;
        if(d[temp]<x)
            l=temp+1;
        else
            r=temp;
    }
    if(x==d[l])
        return 1;
    else
        return 0;
}
int main()
{
    int l,n,m,t=1;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        for(int i=0;i<l;i++)
            scanf("%d",&a[i]);
        sort(a,a+l);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&c[i]);
        int s;
        scanf("%d",&s);
        printf("Case %d:\n",t++);
        len=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                d[len++]=b[i]+c[j];
        sort(d,d+len);
        len=unique(d,d+len)-d;
        for(int i=1;i<=s;i++)
        {
            int x,flag=0;
            scanf("%d",&x);
            for(int j=0;j<l;j++)
            {
                int y=x-a[j];
                if(find(y))
                {
                    flag=1;
                    printf("YES\n");
                    break;
                }
            }
            if(!flag)
                printf("NO\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值