原题
Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
题意
依次给定一组字母的大小关系,并及时判断它们是否能组成唯一的拓扑序列。
涉及知识及算法
题解的强大之处在于灵活利用了入度这个概念,存在解的时候,必须满足只有一个单源点,沿着解这条路走,必然是单源点(入度为零)后面跟着入度为1的点, 然后删除单源点,更新入度,重复,又是仅有一个单源点,且后面跟着入度为1的点,最后仅剩一个单源点。有环的话,随着单源点的删除,最后会出现没有单源点的情况,这个时候就可以判读处理有环。 无序的话,无论什么时候,出现多个单源点都说明无序。
——引自CSDN博主chchlh,附上链接http://blog.csdn.net/chchlh/article/details/41846509,表示感谢。
代码
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n,m;
//最终判断的标记
bool Sign;
//录入字符串
string str;
//入度数组
int indegree[27];
//图
int Map[27][27];
//解空间(队列)
int q[27];
//备份入度顶点
int temp[27];
//拓扑排序
int TopoSort()
{
//记录解空间中零入度顶点的个数
int Count=0;
//记录任一个零入度顶点的位置
int loc;
//记录当前图中零入度顶点数目
int m;
//暂标记为有序
int flag=1;
for(int i=1;i<=n;i++)
{
temp[i]=indegree[i];
}
for(int i=1;i<=n;i++)
{
m=0;
//查找零入度顶点个数
for(int j=1;j<=n;j++)
{
if(temp[j]==0)
{
m++;
//记录一个零入度顶点位置
loc=j;
}
}
//当前图中零入度顶点数目为零一定说明有环
if(m==0)
{
return 0;
}
//无序,但不一定知道是否有环
if(m>1)
{
flag=-1;
}
//该零入度顶点入队
q[Count++]=loc;
//入度置为-1
temp[loc]=-1;
//删除该点
for(int j=1;j<=n;j++)
{
if(Map[loc][j]==1)
{
temp[j]--;
}
}
}
return flag;
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d%d",&n,&m)&&(n||m))
{
memset(Map,0,sizeof(Map));
memset(indegree,0,sizeof(indegree));
Sign=0;
for(int i=1;i<=m;i++)
{
cin>>str;
//一旦确定结果,就对后续的输入不再操作
if(Sign)
{
continue;
}
int u=str[0]-'A'+1;
int v=str[2]-'A'+1;
Map[u][v]=1;
//入度加一
indegree[v]++;
int s=TopoSort();
//有环
if(s==0)
{
printf("Inconsistency found after %d relations.\n",i);
Sign=1;
}
//有序
else if(s==1)
{
printf("Sorted sequence determined after %d relations: ",i);
for (int j=0; j<n; j++)
{
putchar(q[j]+'A'-1); //输出字符 putchar(ASCII)
}
printf(".\n");
Sign=1;
}
}
//无法得出结果
if(!Sign)
{
printf("Sorted sequence cannot be determined.\n");
}
}
return 0;
}
/**************************************************************
Language: C++
Result: Accepted
Time:0 ms
Memory:1508 kb
****************************************************************/
代码引自新浪博客博主康文骐,附上链接http://blog.sina.com.cn/s/blog_676070110100kii1.html,表示感谢。