HDU 4055 Number String(计数dp)

作者:蜘蛛侠

链接:点击打开链接

原题

Number String


Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


Problem Description

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.


Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.


Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.


Sample Input

II
ID
DI
DD
?D
??


Sample Output

1
2
2
1
3
6

Hint


Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.

题意


给一个由'I', 'D', '?'组成的字符串,设该字符串长度为n-1,则该字符串指示了长度为n的,数值为1,2,3……n的一组数字的排列规律。’I’ 和 ‘D‘ 代表分别代表递增或递减,'?' 代表无递增递减要求。求满足这种条件的排列的方案数。

涉及知识及算法

设str存储字符串,设dp[i][j] 表示长度为 i ,以 j 为结尾的排列的方案数。

如果 str[i-1] == 'I'

只要在长度为 i-1 且结尾数字小于 j 的排列后面加个 j 就好了。
 dp[i][j] = dp[i-1][j-1] + dp[i-1][j-2] + … + dp[i-1][1]

如果 str[i-1] == 'D'

似乎只要在长度为 i-1 且结尾数字大于 j 的排列后面加个 j 就好了。
dp[i][j] = dp[i-1][i-1] + dp[i-1][i-2] + … + dp[i-1][j+1]

但是我们要想到长度为i的排列比长度为i-1的排列多一个等于i的数值。但是没有dp[i-1][i]这样的数值,该怎么办?
我们可以设想在长度为 i-1 且结尾数字大于等于 j 的排列中,把大于等于 j 的数字全部加1(不影响之前的递增和递减情况),后面再加个 j 。这样就实现了从1~i-1到1~i的转化。
所以应为
dp[i][j] = dp[i-1][i-1] + dp[i-1][i-2] + … + dp[i-1][j]。

若果 str[i-1] == '?' 

那么 dp[i][j] = dp[i-1][i-1] +dp[i-1][i-2] + … + dp[i-1][1]



转移的复杂度可以通过用 sum 数组记录前缀和优化到 O(1)。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int mod=1000000007;
const int N=1002;

int dp[N][N],sum[N][N];
char str[N];
int main()
{
    //freopen("in.txt","r",stdin);
    dp[1][1]=sum[1][1]=1;
    while(~scanf("%s",str+1))
    {
        int n=strlen(str+1)+1;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                if(str[i-1]=='I')
                    dp[i][j]=sum[i-1][j-1];
                else if(str[i-1]=='D')
                    dp[i][j]=(sum[i-1][i-1]-sum[i-1][j-1]+mod)%mod;
                else
                    dp[i][j]=sum[i-1][i-1];
                sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;
            }
        }
        printf("%d\n",sum[n][n]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值