hdu 4485 B-Casting (数学)

B-Casting

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 370    Accepted Submission(s): 187


Problem Description
Casting around for problems leads us to combine modular arithmetic with different integer bases, particularly the problem of computing values modulo b-1, where b is the base in which the value is represented. For example,

7829 10 mod 9 = 8,
37777777777777773 8 mod 7 = 6
123456 7 mod 6 = 3 

(Note that 37777777777777773 8 = 1125899906842619 10 and 123456 7 = 22875 10.) 

Your job is to write a program that reads integer values in various bases and computes the remainder after dividing these values by one less than the input base.
 

Input
The first line of input contains a single integer P, (1 <= P <= 1000) , which is the number o data sets that follow. Each data set should be processed identically and independently.

Each data set consists of a single line of input containing three space-separated values. The first is an integer which is the data set number. The second is an integer which is the number, B (2 <= B <= 10), denoting a numeric base. The third is an unsigned number, D, in base B representation. For this problem, the number of numeric characters in D will be limited to 10,000,000.
 

Output
For each data set there is a single line of output. It contains the data set number followed by a single space which is then followed by the remainder resulting from dividing D by (B-1).
 

Sample Input
  
  
4 1 10 7829 2 7 123456 3 6 432504023545112 4 8 37777777777777773
 

Sample Output
  
  
1 8 2 3 3 1 4 6
 



对于一个b进制的数,每一位分别是an,...a5,a4,a3,a2,a1,a0;
则变成十进制就是((b)^0*a0)+((b^1)*a1)+......((b^n)*an);
对于其中的一项 求(b^k *ak )%(b-1)
用t=b-1
则变成((t+1)^k*ak)%t
而(t+1)^k%t   展开后显然只剩1了,其他都是t的倍数
所以(b^k *ak )%(b-1)=ak%(b-1)
.......

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int p,a,b;
char s[10000000+1];
int main()
{
    scanf("%d",&p);
    while(p--)
    {
        scanf("%d%d%s",&a,&b,s);
        int j=0;
        int ans=0;
        int l=strlen(s)-1;
        for(int i=l;i>=0;i--)
        {
            ans+=(s[i]-'0')%(b-1);
            ans%=b-1;
        }
        printf("%d %d\n",a,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值