POJ - 2348:Euclid's Game

POJ - 2348 Euclid’s Game
https://www.cnblogs.com/kuangbin/p/3204627.html 大神讲的很好

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
25 7
11 7
4 7
4 3
1 3
1 0
an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12
15 24
0 0
Sample Output
Stan wins
Ollie wins

题目给出了两个正数a.b
每次操作,大的数减掉小的数的整数倍。一个数变为0 的时候结束。
谁先先把其中一个数减为0的获胜。问谁可以赢。Stan是先手。

假设两个数为a,b(a>=b)

  1. 如果a % b == 0.那么肯定是先手获胜。一步就可以减为0,b 。
  2. 如果a >= 2*b. 那么 状态可以转化为 ( a%b,b ) 或 ( a%b+b,b ) ;这两种必定有一个是先手必胜态,即先手赢。
  3. 如果是 b < a < 2*b 那么状态只能转化为(a-b,b) .这样一直下去直到面对一个 a%b==0 || a >=2*b 的状态。

附大神代码:

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main() {
    int a, b;
    while (scanf("%d%d", &a, &b) == 2) {
        if ( a == 0 && b == 0)
            break;
        if ( a < b)
            swap(a, b);
        int win = 0;
        while (b) {
            if ( a % b == 0 || a / b >= 2)
                break;
            a = a - b;
            swap(a, b);
            win ^= 1;
        }
        if (win == 0)
            printf("Stan wins\n");
        else
            printf("Ollie wins\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值