Euclid's Game
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12822 | Accepted: 5138 |
Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
25 7 11 7 4 7 4 3 1 3 1 0
an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12 15 24 0 0
Sample Output
Stan wins Ollie wins
题意分析:
Stan 和 Ollie玩游戏,从两个自然数a,b开始,第一个玩家,从两个数字中的较大数字减去两个数字中较小数字的任何正倍数,所得数字必须是非负数。第二个玩家执行相同步骤,直到一个玩家能够从较大数字中减去较小数字的倍数以达到 0,从而获胜。
解题思路:
设a是较大的数
当a==b时,先手必胜;
当a=a+b时,后手必胜,因为先手只能把(a+b,b)变为(a,b);
当a=a+k*b时(k为任意正整数),先手都能胜,因为先手总是可以把(a+k*b,b)变为(a+b,b);
换句话说即谁先能做选择,谁就必胜
剩下的情况只有 b<a<2*b
这种情况是无法自己选择的,只能根据减了多少次变为零,和奇数是谁胜,偶数是谁胜。
错误分析:
注意这里面的数据要用 long long !!
ac代码:
#include<iostream>
using namespace std;
int main()
{
long long n,m;
while(cin>>n>>m)
{
if(n==0 && m==0) break;
if(n<m) swap(n,m);
long long flag=1;
while(1)
{
if(n>=2*m||m==0||n%m==0) break;
long long t;
t=n;
n=m;
m=t-m;
flag^=1;
}
if(flag) cout<<"Stan wins"<<endl;
else cout<<"Ollie wins"<<endl;
}
return 0;
}