HDU - 1016 Prime Ring Problem DFS

Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

因为最大只到20,所以两个数字之和顶多也就39,那么可以直接把范围内的素数列出来然后用find函数就好。
剩下的还有能说的就是别忘了判断最后一个元素和1的和是不是素数。
关于空格和换行除了if-else也可以用条件运算符

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
const vector<int> prime={2,3,5,7,11,13,17,19,23,29,31,37};
void circle(int pos,int n);
int isok(void);
void print(int n);
int arr[20],num[20];
int main()
{
    int t=0,x,i;
    while(cin>>x&&x>0&&x<20){
        cout<<"Case "<<++t<<":\n";
        for(i=0;i<x;++i){
            arr[i]=1;
            num[i]=0;
        }
        num[0]=1;
        circle(1,x);
        cout<<endl;
    }
}
void circle(int pos,int n)
{
    if(pos==n){
        if(find(prime.begin(),prime.end(),num[pos-1]+1)!=prime.end())//我把判断放在这里了
            print(n);
    }else{
        for(int i=1;i<n;++i){
            if(arr[i]&&find(prime.begin(),prime.end(),num[pos-1]+i+1)!=prime.end()){
                arr[i]=0;
                num[pos]=i+1;
                circle(pos+1,n);
                arr[i]=1;
            }
        }
    }
}
void print(int n)
{
    for(int i=0;i<n;++i){
        cout<<num[i];
        if(i==n-1){
            cout<<endl;
        }else{
            cout<<' ';
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值