HDU - 5999 The Third Cup is Free 贪心

The Third Cup is Free

Panda and his friends were hiking in the forest. They came across a coffee bar inside a giant tree trunk.
Panda decided to treat everyone a cup of coffee and have some rest. Mr. Buck, the bartender greeted Panda and his animal friends with his antler. He proudly told them that his coffee is the best in the forest and this bar is a Michelin-starred bar, thats why the bar is called Starred Bucks.
There was a campaign running at the coffee bar: for every 3 cups of coffee, the cheapest one is FREE. After asking all his friends for their flavors, Panda wondered how much he need to pay.

Input

The first line of the input gives the number of test cases, T.
T test cases follow. Each test case consists of two lines. The first line contains one integer N, the number of cups to be bought.
The second line contains N integers p1,p2,・・・,pNp1,p2,・・・,pN representing the prices of each cup of coffee.

Output

For each test case, output one line containing “Case #x: y”, where x is the test case number (starting from 1) and y is the least amount of money Panda need to pay.
limits

∙∙ 1 ≤ T ≤ 100.
∙∙ 1 ≤ N ≤ 105.
∙∙ 1 ≤ pi ≤ 1000.

Sample Input

2
3
1 2 3
5
10 20 30 20 20

Sample Output

Case #1: 5
Case #2: 80

这个应该算贪心算法里的基础题吧,为了得到最小值,那么也就是说每次免费我们都要争取到最大的价值,但是又是三杯里面最便宜的一杯免费。
所以实现超简单的啦,排序,从最大的开始,加两个,忽略一个,加两个,忽略一个,完事。

代码

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int coffee[100000];
int main()
{
    int n,m,k;
    scanf("%d",&m);
    for(k=0;k<m;){
        scanf("%d",&n);
        int i,j=n-n/3,temp,sum=0;
        for(i=0;i<n;++i){
            scanf("%d",&coffee[i]);
        }
        sort(coffee,coffee+n);
        for(i=n-1,j=1;i>=0;--i,++j){
            if(j%3){
                sum+=coffee[i];
            }
        }
        printf("Case #%d: %d\n",++k,sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值