The Third Cup is Free

Panda and his friends were hiking in the forest. They came across a coffee bar inside a giant tree trunk.
Panda decided to treat everyone a cup of coffee and have some rest. Mr. Buck, the bartender greeted Panda and his animal friends with his antler. He proudly told them that his coffee is the best in the forest and this bar is a Michelin-starred bar, thats why the bar is called Starred Bucks.
There was a campaign running at the coffee bar: for every 3 cups of coffee, the cheapest one is FREE. After asking all his friends for their flavors, Panda wondered how much he need to pay.
Input
The first line of the input gives the number of test cases, T.
T test cases follow. Each test case consists of two lines. The first line contains one integer N, the number of cups to be bought.
The second line contains N integers p1,p2,・・・,pNp1,p2,・・・,pN representing the prices of each cup of coffee.
Output
For each test case, output one line containing “Case #x: y”, where x is the test case number (starting from 1) and y is the least amount of money Panda need to pay.
limits

∙∙ 1 ≤ T ≤ 100.
∙∙ 1 ≤ N ≤ 105105.
∙∙ 1 ≤ pi ≤ 1000.

Sample Input
2
3
1 2 3
5
10 20 30 20 20
Sample Output
Case #1: 5
Case #2: 80
三杯中减去最便宜一杯,由大到小进行快排,可使快速计算出总需付款
代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
bool ac(int a,int b)
{
    return a>b;
}
int main()
{
    int T,N,p[100001];
    int t=1;
    scanf("%d",&T);
    while(T--)
    {

        int ans=0;
        scanf("%d",&N);
        for(int i=1;i<=N;i++)
            scanf("%d",&p[i]);
        printf("Case #%d: ",t);
        t=t+1;
        sort(p+1,p+N+1,ac);//sort排序是从零开始的,所以+1才可使下表相符
        for(int i=1;i<=N;i++)
        {
            if(i%3!=0)
                ans=ans+p[i];
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值