POJ3159-Candies-最短路

POJ3159-Candies-最短路

Time Limit: 1500MSMemory Limit: 131072K
Total Submissions: 32821Accepted: 9192

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

POJ Monthly–2006.12.31, Sempr


思路

差分约束系统,思路查看算导最短路那一章的末尾,理解了这个题就是裸的模板题了

顺便题目说的是1比N多的最多个数,而不是差值

AC代码

#include <cstdio>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <vector>
#include <queue>
#include <cctype>
#include <cmath>
#include <algorithm>
#include <set>
#include <bitset>
#include <map>
#define INF 0x3f3f3f3f
#define ULL unsigned long long
#define LL long long
#define N 1000100
#define eps 10e-9
#define MOD 100000000
#define mem(a,n) memset(a,n,sizeof(a))
#define fread freopen("in.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)
using namespace std;
LL d[N];
int head[N],nodes,st[N],top,cnt[N],n;
bool inque[N];
struct Edge{
    int from,to,dist,next;
}edges[N];

void init(int n,int m){
    for(int i=0;i<=n;++i){
        d[i]=INF;
        inque[i]=false;
    }
    for(int i=0;i<=m;++i){
        head[i]=-1;
    }
    top=0;
}

void AddEdge(int from,int to,int dist){
    edges[nodes].from=from,edges[nodes].to=to,edges[nodes].dist=dist;
    edges[nodes].next=head[from];
    head[from]=nodes++;
}

void spfa(int s)
{
    d[s]=0;
    st[top++]=s;
    while(top>0){
        int u=st[--top];
        inque[u]=false;
        for(int i=head[u];i>=0;i=edges[i].next){
            Edge &e=edges[i];
            if(d[e.to]>d[e.from]+e.dist){
                d[e.to]=d[e.from]+e.dist;
                if(!inque[e.to]){
                    inque[e.to]=true;
                    st[top++]=e.to;
                }
            }
        }
    }
}
int main()
{
    int m,u,v,c;
    while(~scanf("%d%d",&n,&m)){
        init(n,m);
        while(m--){
            scanf("%d%d%d",&u,&v,&c);
            AddEdge(u,v,c);
        }
        spfa(1);
        printf("%d\n",d[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值