Candies ( POJ 3159)

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow Mlines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;

//BY 郭炜老师;
// Dijkstra算法求解最短路径;

struct CNode{
    int k;//有向边的终点;
    int w;//权值,或k到已经求出最短路的那些点的最短距离;
};

bool operator < ( const CNode & d1, const CNode & d2)
{
    return d1.w > d2.w;//w大的,被视为更小,而优先队列总将最大的元素出列;
    //因此w小的更早出列;
}

priority_queue<CNode> pq;//优先队列;
bool bUsed[30010] = {0};
vector<vector<CNode> > v;//v是整个图的临接表;
const unsigned int INFINITE = 100000000;

int main()
{
    int N, M, a, b, c;
    cin >> N >> M;
    v.clear();
    v.resize(N + 1);
    memset(bUsed, 0, sizeof(bUsed));
    CNode p;
    for (int i = 1; i <= M; i++)
    {
        cin >> a >> b >> c;
        p.k = b;
        p.w = c;
        v[a].push_back(p);
    }
    p.k = 1;
    p.w = 0;
    pq.push(p);//对pq进行初始化;
    while (!pq.empty())
    {
        p = pq.top();
        pq.pop();
        if ( bUsed[p.k]) //该点已被纳入最短路;
            continue;
        bUsed[p.k] = true; //纳入最短路径;
        if (p.k == N) //已经抵达终点;
            break;
        for (int i = 0; i < v[p.k].size(); i++) //
        {//寻找从已确认路径出发的,抵达相邻未到达点的最短连线;
            CNode q;
            q.k = v[p.k][i].k;
            if (bUsed[q.k]) //要求这个点没有被包含在已被确认的最短路径内;
                continue;
            q.w = p.w + v[p.k][i].w;
            pq.push(q); //队列里有终点为q.k的元素也没关系,不合适的会被直接跳过,通过if(bUsed[p.k])这一判断语句;
        }
    }
    cout << p.w;
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值