Codeup-6112:Be Unique (20)

题目描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

样例输入

7 5 31 5 88 67 88 17
5 888 666 666 888 888

样例输出

31
None

这一题的思路也是设置hashtable,然后判断hashtable[ i ]的值,但是调试了多次依然25%错误,最后发现刚开始两个数组的大小有一个设置小了,导致一直报错。

具体代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;



int main()
{
	int n;
	while (scanf("%d", &n) != EOF)
	{
		int a[100010];
		int hashtable[100010] = { 0 };
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &a[i]);
			hashtable[a[i]]++;
		}
		int temp=0;
		for (int i = 0; i < n; i++)
		{
			if (hashtable[a[i]] == 1)
			{
				printf("%d\n", a[i]);
				temp = 1;
				break;
			}
		}
		if (temp == 0)
			printf("None\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值