题目描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
输入
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
输出
For each test case, print the winning number in a line. If there is no winner, print "None" instead.
样例输入 Copy
7 5 31 5 88 67 88 17 5 888 666 666 888 888
样例输出 Copy
31 None
超时代码: 习惯使用容器的弊端。。老想着套用容器去模拟过程,结果忽略了map自动排序问题;接着使用结构体模拟,但是忽视了n<= 10的5次,出现超时情况。最后使用最简单的一维数组去模拟,桶排序直接统计,然后依次判断一维数组中元素的个数是否为1,是则直接输出,再break;若遍历完仍然找到(即ans = 0),则输出none。。。。(明明很简单。。。但是不知道自己脑回路怎么绕的。。。。可能还是自己太菜了。。。)最下方是满分代码。。很简单。。。
#include<bits/stdc++.h>
using namespace std;
struct num{
int number;
int times;
num(){
number = 0;
times = 0;
}
};
int main(){
int n;
while(scanf("%d",&n) != EOF){
num m[n];
int num;
for(int i = 0; i < n; i++){
scanf("%d",&num);
for(int i = 0; i < n; i++){
if(m[i].number == 0){
m[i].number = num;
m[i].times++;
break;
}else if(m[i].number == num){
m[i].times++;
break;
}
}
}
int ans = 0;
for(int i = 0; i < n; i++){
if(m[i].times == 1){
ans = m[i].number;
break;
}
}
if(ans == 0) printf("None\n");
else printf("%d\n",ans);
}
}
满分代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int n;
while(scanf("%d",&n) != EOF){
int flag[100010] = {0};
int num[n];
int res = 0;
for(int i = 0; i < n; i++){
scanf("%d",&num[i]);
flag[num[i]]++;
}
int ans = 0;
for(int i = 0; i < n; i++){
if(flag[num[i]] == 1){
ans = num[i];
break;
}
}
if(ans == 0) printf("None\n");
else printf("%d\n",ans);
}
}