poj 2287 Tian Ji -- The Horse Racing(贪心)

43 篇文章 0 订阅

 

Description

Here is a famous story in Chinese history. 

That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others. 

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser. 

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian. 

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match. 

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China? 


Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching... 

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem. 

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n ( n<=1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses. Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0

解题思路:输入记录后,排序两个人a,b的马

               1:当a最慢的马比b最慢的马低时,跟b最快的马比(反正都是输,消耗最快的)

               2:当a最慢的马比b最慢的马慢时,跟b最慢的马比 (最慢的都能赢肯定要赢的)

               3 : 当min (a) ==min(b)时,看最快的a马和最快的b马比

                   3.a max(a)>max(b)时,先用最快的赢一场(能赢先赢)

                   3.b max(a)<max(b),  最慢的a马跟b最快的比(反正都要输一场,用最慢的输,可能你会误会,为什么打平不行非要输一场,换个角度,我迟早会跟b最快的马比,我所有马都会输,那我拿最低的换了它,就算改变不了大局,我随便一匹也能跟他最慢的比换回来,所以这时最差的情况才是打平,换是最好的)  

                   3.c max(a)==max(b),同上,平两场,我最低换最高的话,最差情况就是平,好的话整个大局就变了。

 附上代码

 

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;

int main()
{
    int a[1005],b[1005],temp,ans,ping,kai,jie,ajie;
    int n,i,j;
    while(cin>>n)
    {
        if(n==0)
            break;
        ans=0;
        ping=0;
        for(i=0;i<n;i++)
        cin>>a[i];
         for(i=0;i<n;i++)
            cin>>b[i];
         sort(a,a+n);
         sort(b,b+n);
         kai=0;
         jie=n-1;
         ajie=n-1;
         for(i=0;i<=ajie;i++)
         {
             if(a[i]>b[kai]) //最慢的能赢
             {
                 ans++;
                 kai++;
             }
             else if(a[i]==b[kai])//最慢的一样
             {
               if(a[ajie]>b[jie])//最快的能赢
               {
                   ajie--;
                   jie--;
                   ans++;
                   i--;
               }
               else if(a[ajie]==b[jie])//最慢最快都一样
               {
                   if(a[i]<b[jie])
                   {
                    jie--;
                   ans--;
                   }
                   else
                     jie--;
               }
               else
               {
                   jie--;
                   ans--;
               }
             }
             else
             {
                 jie--;
                 ans--;
             }
         }
         cout<<ans*200<<endl;
    }
    return 0;
}

 

 

 

 

 

 

sss

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值