HDU - 1789 Doing Homework again(贪心,数组优先后放)

43 篇文章 0 订阅

 

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

InputThe input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
OutputFor each test case, you should output the smallest total reduced score, one line per test case. 
Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

 

题意:给定功课的期限和价值,输出最小缩减分数。

 

贪心思路:按价值排序,从大的开始选择(最优选择),日期尽量靠后,如果该日期有人,则向前一位,如果没有位置了,只能不做了,因为是按价值取得,后面选的肯定比前面小价值,那我根本没理由把高价值的替换为低价值的。

避免超时,可以记录一下最早的位置在哪里,方便判断。

#include <cstdio>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

struct kecheng
{
    long long int qixian,value;
}ke[1005];

int cmp(kecheng a,kecheng b)
{
    if(a.value>b.value)
        return 1;
    return 0;
}
long long int min(long long int a,long long int b)
{
    if(a<b)
        return a;
    return b;
}

int main()
{
   long long int n,m,i,j,cas,w,wei,sum;
    long long int qixian[1005],value[1005],ok;
    int ans[1005];
    scanf("%lld",&cas);
    for(w=1;w<=cas;w++)
    {
        sum=0;
        memset(ans,-1,sizeof(ans));
       scanf("%lld",&n);
        for(i=0;i<n;i++)
        scanf("%lld",&ke[i].qixian);
        for(i=0;i<n;i++)
      scanf("%lld",&ke[i].value);
        sort(ke,ke+n,cmp);
       for(i=0;i<n;i++)
       {
           ok=0;
         wei=min(ke[i].qixian,n);
         for(;wei>=1;wei--)//找合法空位
         {
             if(ans[wei]==-1)//没人
             {
                 ans[wei]=i;
                 ok=1;
                 break;
             }

         }
       //   cout<<"a";
         if(ok==0)//没有合法位置
         {
         //    cout<<"b";
             for(wei=n;wei>=1;wei--)
             {
                 if(ans[wei]==-1)//违法坐下
                 {
                     ans[wei]=i;
                     sum+=ke[i].value;
                     break;
                 }
             }
         }
       }
printf("%lld\n",sum);
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值