Description
将字符串t插入到字符串s中,在位置pos后插入。不得使用字符串操作函数,输出组合成的字符串。
Input
输入两个字符串(t和s)和要插入的位置(pos)
Output
输出组合后的字符串
Sample Input**
qwe
jij
3
Sample Output
将字符串t插入到字符串s中,在位置pos后插入。不得使用字符串操作函数,输出组合成的字符串。
Input
输入两个字符串(t和s)和要插入的位置(pos)
Output
输出组合后的字符串
Sample Input**
qwe
jij
3
Sample Output
jijqwe
#include <stdio.h>
#include <stdlib.h>
int main()
{
char c1[20],c2[20];
int a,i,j;
gets(c1);
gets(c2);
scanf("%d",&a);
for(i=0; c1[i]!='\0'; i++)
{
if(i==a)
{
for(j=0; c1[j]!='\0'; j++)
{
printf("%c",c1[j]);
}
}
printf("%c",c2[i]);
}
return 0;
}