动态规划——hdu1003

网上的人都说hdu1003是一道dp水题,我却wa了2天,不过,不管怎么说,还是过了,简单的总结一下吧


上题:

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6


思路大致为:用一个数组dp[100505]记录如果以第i个元素作为子序最后一个元素所能达到的最大值,那么dp数组中的最大值就是最大子序的最大值,而下标就是最大子序的最后一个元素的位置,再根据递推公式得到最大子序第一个元素的位置,公式为  dp[i]=(dp[i-1]>0?)dp[i-1]+a:a  a就是原序列中第i个元素


上代码:

#include<stdio.h>
int dp[100505];//用来记录子序以第i个元素结尾时的最大值
int Max,s,e;
int main()
{
    int n,t,a;
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            if(i==1)
            {
                dp[i]=a;
                Max=dp[i];
                e=i;
            }
            else
            {
                dp[i]=(dp[i-1]>0)?(dp[i-1]+a):a;//关键公式
            }
            if(Max<dp[i])
            {
                Max=dp[i];
                e=i;
            }
        }
        s=e;
        for(int j=e-1;j>=1;j--)
        {
            if(dp[j]>=0)
                s=j;
            else
                break;//不要忘了break
        }
        if(k<t)
            printf("Case %d:\n%d %d %d\n\n",k,Max,s,e);
        else
            printf("Case %d:\n%d %d %d\n",k,Max,s,e);
    }
    return 0;
}

非dp做法还在探索中。。。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值