Description |
创建一个一维数组,指定该一维数组的大小n,输入数组的n个元素,输入要查找的数值kval,利用设置"哨兵"查找其关键字等于 kval 的数据元素,若找到,则函数值为该元素在表中的位置(1-n),否则为0,并输出结果。 Input |
Sample Input |
6 23 34 45 56 67 78 45 |
Sample Output |
3 |
Hint |
输出无换行 |
#include <bits/stdc++.h>
using namespace std;
typedef struct
{ // 可定义多种不同类型的数据类型
int key;
int info; // 其他数据类型的权值
} Elem;
typedef struct
{
Elem *R; // 数组表基址一般下标为0不存值
int len; // 长度
} Stable;
void initST(Stable &ST)
{ // 线性初始化
ST.R = new Elem[100];
}
int serch_stpro(Stable ST, int key1)
{ // 0下标的为哨兵
ST.R[0].key = key1;
int i;
for (i = ST.len; ST.R[i].key != key1; i--)
;
return i;
}
void creat_ST(Stable &ST, int n)
{ // 创建线性数组
ST.len = n;
for (int i = 1; i <= ST.len; i++)
{
cin >> ST.R[i].key;
}
}
int main()
{
Stable ST;
initST(ST);
int n, key, num;
cin >> n;
creat_ST(ST, n);
cin >> key;
num = serch_stpro(ST, key);
cout << num;
return 0;
}