试题 算法训练 排序
资源限制
时间限制:1.0s 内存限制:512.0MB
问题描述
编写一个程序,输入3个整数,然后程序将对这三个整数按照从大到小进行排列。
输入格式:输入只有一行,即三个整数,中间用空格隔开。
输出格式:输出只有一行,即排序后的结果。
输入输出样例
样例输入
9 2 30
样例输出
30 9 2
#include <iostream>
#include <algorithm>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int cmp(int a,int b)
{
if(a>b)
{
return 1;
}
else{
return 0;
}
}
int main(int argc, char *argv[]) {
int a[5];
int i;
for(i=0;i<3;i++)
scanf("%d",&a[i]);
sort(a,a+3,cmp);
for(i=0;i<3;i++)
printf("%d ",a[i]);
return 0;
}
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
//printf("yes");
int a,b,c;
scanf("%d %d %d",&a,&b,&c);
if(a>=b)
{
if(b>=c)
{
printf("%d %d %d",a,b,c);
}
else if(c>a){
printf("%d %d %d",c,a,b);
}
else{
printf("%d %d %d",a,c,b);
}
}
//b>=a
else{
if(a>=c)
{
printf("%d %d %d",b,a,c);
}
else if(c>=b){
printf("%d %d %d",c,b,a);
}
else{
printf("%d %d %d",b,c,a);
}
}
return 0;
}