Requested 'libusbmuxd >= 1.1.0' but version of libusbmuxd is 1.0.10解决办法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ZuoWeiXiaoDuZuoZuo/article/details/83413074

遇见问题

在部署Flutter运行环境时遇见一个问题:
在终端执行 flutter doctor:下面报错,并提示

	brew install --HEAD libimobiledevice
	brew install ideviceinstaller

然后我们当然是执行了这两句话,

但是很多人执行完了之后再次在终端执行 flutter doctor 仍然会提醒

	brew install --HEAD libimobiledevice
	brew install ideviceinstaller

发现问题原因

这两句话,如果这样 首先退出终端,然后打开终端。
再次运行flutter doctor,看一下是不是因为我们没有因为没有更新资源导致的问题。
如果仍然报错,那么我们有理由相信,我们的

	brew install --HEAD libimobiledevice
	brew install ideviceinstaller

这两行代码可能并没有正确的执行,那么我们就再执行一次,看一下到底是什么问题。

其中之一就是

	Requested 'libusbmuxd >= 1.1.0' but version of libusbmuxd is 1.0.10

这条信息相当的重要。

告诉了我们你的某个系统组件版本过低,那么怎么办呢?
当然是升级了咯!!

寻找解决办法,升级libusbmuxd

按顺序执行以下命令

	brew uninstall --ignore-dependencies libimobiledevice
	brew uninstall --ignore-dependencies usbmuxd
	brew install --HEAD usbmuxd
	brew unlink usbmuxd
	brew link usbmuxd

最后我们再次执行

	brew install --HEAD libimobiledevice

验证问题是否被解决

终端再次执行

	flutter doctor

查看结果 下面为正常结果

Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel beta, v0.9.4, on Mac OS X 10.14 18A391, locale zh-Hans-CN)
[✓] Android toolchain - develop for Android devices (Android SDK 28.0.2)
[✓] iOS toolchain - develop for iOS devices (Xcode 10.0)
[✓] Android Studio (version 3.2)
[✓] VS Code (version 1.28.2)
[!] Connected devices
    ! No devices available

! Doctor found issues in 1 category.

相关链接

阅读更多
换一批

没有更多推荐了,返回首页