PAT甲级练习1023. Have Fun with Numbers (20)

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
计算加倍后数字出现的频数是否和原数一致,挺简单的一题,但是也卡了一会。。。

一开始用另一个数组x2保存各数字的频数,但测试点四通不过,之后改成了直接在x1上减,判断最后是不是都为零进行判断,没想通为什么。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <string.h>

using namespace std;

char c1[22], c2[22];
int x1[10],x2[10];

int main(){
	
	scanf("%s", c1);
	int len=strlen(c1);
	int flag=0, tmp1, tmp2, cnt=0;
	for(int i=len-1; i>=0; i--){
		tmp1 = c1[i] - '0';
		x1[tmp1]++;
		tmp2 = 2 * tmp1 + flag;
		flag = tmp2 / 10;
		c2[cnt++] = tmp2 % 10 + '0';
		x1[tmp2%10]--;
		if(i==0 && flag==1){
			c2[cnt] = '1';
			x1[1]--;
		}
	}
	int flag1=0;
	for(int i=0; i<10; i++){
		if(x1[i]!=0) flag1=1;
	}

	if(flag1==0)
		cout<<"Yes"<<endl;
	else
		cout<<"No"<<endl;
	
	for(int i=strlen(c2)-1; i>=0; i--){
		printf("%d", c2[i]-'0');
	}
	cout<<endl;
	cin>>c1;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值