PAT甲级练习1054. The Dominant Color (20)

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
简单统计,用数组保存遍历通过,但是时间有点危险的感觉。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <string>
#include <string.h>

using namespace std;

const int MAX=2e7+10;

int n, m, a, cnt[MAX];

int main(){

	scanf("%d%d", &n, &m);

	for(int i=0; i<m; i++){
		for(int j=0; j<n; j++){
			scanf("%d", &a);
			cnt[a]++;
		}
	}
	int c = n * m;
	for(int i=0; i<MAX; i++){
		if(cnt[i]>c/2){
			printf("%d\n", i);
			break;
		}	
	}

	cin>>n;
	return 0;
}

评测结果

时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
2月26日 10:59 答案正确 20 1054 C++ (g++ 4.7.2) 93 384 shower

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 11 384 12/12
1 答案正确 4 384 2/2
2 答案正确 93 384 2/2
3 答案正确 7 384 2/2
4 答案正确 14 384 2/2


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值