PAT甲级1054:The Dominant Color (20)

题目

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

解题思路

本题首先读入数据,为了统计各个数字出现次数方便起见,将所有像素点存入一个向量当中;在对该向量进行qsort后遍历,此时相同的像素值会连续出现,找出出现次数最多的像素点,存储它的像素值和出现次数;最后通过判断最大出现次数是否大于所有像素点数目的一半决定是否输出。

易错点

  1. 测试点4:测试当像素点个数为1是否能够正确输出;
  2. 像素点的值需要设为long int类型,像素点个数只需int即可。

代码

#include<bits/stdc++.h>
using namespace std;

int cmp(const void* a,const void* b){
    long int c = *(long int*)a;
    long int d = *(long int*)b;
    return (c<=d)?-1:1;//升序
}

int main(){
    int r,c,i,j,k=0,num=1,max=0;
    scanf("%d %d",&c,&r);
    int total = r*c;
    long int M,a[total];//digital colors in the range [0,2^24)
    for (i=0;i<r;i++)
        for (j=0;j<c;j++)
            scanf("%ld",&a[k++]);
    M = a[0];
    max = 1;//赋予初值,防止仅有一个数字的时候无输出
    qsort(a,k,sizeof(long int),cmp);    
    for (i=1;i<total;i++)
    {
        num = (a[i-1]==a[i])?(num+1):1;
        if (num>max)
        {
            max = num;
            M = a[i];
        }
    }
    if (max>(total/2))
        printf("%ld",M);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值