描述
Ural大学有N名职员,编号为1~N。他们的关系就像一棵以校长为根的树,父节点就是子节点的直接上司。每个职员有一个快乐指数,用整数 H_i 给出,其中 1≤i≤N。现在要召开一场周年庆宴会,不过,没有职员愿意和直接上司一起参会。在满足这个条件的前提下,主办方希望邀请一部分职员参会,使得所有参会职员的快乐指数总和最大,求这个最大值。输入格式
第一行一个整数N。(1<=N<=6000)
接下来N行,第i+1行表示i号职员的快乐指数H_i。(-128<=H_i<=127)
接下来N-1行,每行输入一对整数L, K。表示K是L的直接上司。
最后一行输入0,0。输出格式
输出最大的快乐指数。样例输入
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
样例输出
5
树形dp
#include<bits/stdc++.h>
using namespace std;
#define rep(i,j,k) for(int i = j;i <= k;++i)
#define repp(i,j,k) for(int i = j;i >= k;--i)
#define rept(i,x) for(int i = linkk[x];i;i = e[i].n)
#define P pair<int,int>
#define Pil pair<int,ll>
#define Pli pair<ll,int>
#define Pll pair<ll,ll>
#define pb push_back
#define pc putchar
#define mp make_pair
#define file(k) memset(k,0,sizeof(k))
#define fr first
#define se second
#define ll long long
const int p = 1e9;
/*namespace fastIO{
#define BUF_SIZE 100000
#define OUT_SIZE 100000
bool IOerror = 0;
inline char nc(){
static char buf[BUF_SIZE],*p1 = buf+BUF_SIZE, *pend = buf+BUF_SIZE;
if(p1 == pend){
p1 = buf; pend = buf+fread(buf, 1, BUF_SIZE, stdin);
if(pend == p1){ IOerror = 1; return -1;}
}
return *p1++;
}
inline bool blank(char ch){return ch==' '||ch=='\n'||ch=='\r'||ch=='\t';}
inline void read(int &x){
bool sign = 0; char ch = nc(); x = 0;
for(; blank(ch); ch = nc());
if(IOerror)return;
if(ch == '-') sign = 1, ch = nc();
for(; ch >= '0' && ch <= '9'; ch = nc()) x = x*10+ch-'0';
if(sign) x = -x;
}
inline void read(ll &x){
bool sign = 0; char ch = nc(); x = 0;
for(; blank(ch); ch = nc());
if(IOerror) return;
if(ch == '-') sign = 1, ch = nc();
for(; ch >= '0' && ch <= '9'; ch = nc()) x = x*10+ch-'0';
if(sign) x = -x;
}
#undef OUT_SIZE
#undef BUF_SIZE
};
using namespace fastIO;*/
void read(int &x) {scanf("%d",&x);}
vector<int>G[6001];
int dp[6001][2];
int v[6001] , fa[6001];
bool vis[6001];
int n , root;
void dfs(int x)
{
rep(i,1,G[x].size())
if(G[x][i-1] != fa[x])
{
dfs(G[x][i-1]);
int y = G[x][i-1];
dp[x][1] += dp[y][0];//参加
dp[x][0] += max(dp[y][1],dp[y][0]);
}
dp[x][1] += v[x];
}
int main()
{
read(n);rep(i,1,n) read(v[i]);
rep(i,1,n-1)
{
int x,y;read(x);read(y);
fa[x] = y;vis[x] = true;
G[x].pb(y);G[y].pb(x);
}
rep(i,1,n) if(!vis[i]) root = i;
dfs(root);
printf("%d\n",max(dp[root][0],dp[root][1]));
return 0;
}