Stockbroker Grapevine (弗洛伊德)

Problem Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. <br> <br>Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. <br> <br>

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. <br>It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input
  
  
3 2 2 4 3 5 2 1 2 3 6 2 1 2 2 2 5 3 4 4 2 8 5 3 1 5 8 4 1 6 4 10 2 7 5 2 0 2 2 5 1 5 0

Sample Output
  
  
3 2 3 10

题目大概:

有很多点,他们之间有很多有向路径,两点之间互相走长度不一定相等。

思路:

这个题是求把所有的点都连接在一起后的最小值,刚开始,我想的是用并查集做,因为把所有点用最短的路连起来就是树,但是这个题是双向的,是有向的,两个点互相走的路径不一样,所以适合无向图的最小生成树算法就不行了,要用最短路径算法弗洛伊德,弗洛伊德之后算出了各个点之间的最小值,然后从一个点出发,找出最大值,就是所有点连通的最大值(除非不连通),以所有的点为起点找出最大值后,再取最小值,就是全部联通的最小值了。就是找每一行最大值的最小值。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int map[102][102];
int sum,sun,p;
int ma=100000;
int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)break;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        map[i][j]=ma;
        for(int i=1;i<=n;i++)
        {int m;
        cin>>m;
        for(int j=1;j<=m;j++)
        {
            int x1,y1;
            cin>>x1>>y1;
            map[i][x1]=y1;


        }

        }

        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(i!=k&&k!=j&&i!=j&&map[k][j]<ma&&map[i][j]>map[i][k]+map[k][j])
                    {
                        map[i][j]=map[i][k]+map[k][j];
                    }
                }
            }
        }


        sum=ma;

        for(int i=1;i<=n;i++)
        {   sun=0;
            for(int j=1;j<=n;j++)
            {   if(i==j)continue;
                sun=max(sun,map[i][j]);

            }
            if(sum>sun)
            {
                sum=sun;
                p=i;
            }

        }
        if(sum==ma)cout<<"disjoint"<<endl;
        else cout<<p<<" "<<sum<<endl;



    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值