G - Stockbroker Grapevine

题目:

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 
 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题意:

一场信息风波,让你传播消息,每个人只相信自己认识的人传播的信息,问你最快的速度是由哪个人,耗时多久才传播完的;

给你一个数n,代表有n个人,下面有n行数字,分表代表1--n个人认识的人和传播的耗时,包括一个数字m,代表他认识m个人,然后跟着m对数据a,b,代表他认识a,把信息传递给a耗时b;

让你求出来由哪个人开始传播信息耗时最少,输出那个人的编号和耗时;

思路:

这道题是最短路的变形,我们需要枚举每一个人传播信息的耗时情况,然后遍历比较,找出来这个人就可以了;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int inf=0x3f3f3f3f;

int e[110][110];
int n,m;
int a,b;

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        int i,j,k;
        memset(e,inf,sizeof e);//初始化;
        for(i=1; i<=n; i++)
            e[i][i]=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&m);
            for(j=1; j<=m; j++)
            {
                scanf("%d%d",&a,&b);
                e[i][a]=b;//记录;
            }
        }
        //Floyd-Warshall
        for(k=1; k<=n; k++)
        {
            for(i=1; i<=n; i++)
            {
                for(j=1; j<=n; j++)
                {
                    e[i][j]=min(e[i][j],e[i][k]+e[k][j]);
                }
            }
        }
        int minn=inf,sum=0,kk;
        for(i=1; i<=n; i++)
        {
            sum=0;
            for(j=1; j<=n; j++)//只有耗时最大的传播完了,才代表整个信息传播结束了;
            {
                sum=max(e[i][j],sum);
            }
            if(sum<minn)
            {
                kk=i;//记录是哪个人;
                minn=sum;//传播耗时;
            }
        }
        if(minn==inf)
            printf("disjoint\n");
        else
            printf("%d %d\n",kk,minn);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值