Problem M (树状数组)

Problem Description
There are n men ,every man has an ID(1..n).their ID is unique. Whose ID is i and i-1 are friends, Whose ID is i and i+1 are friends. These n men stand in line. Now we select an interval of men to make some group. K men in a group can create K*K value. The value of an interval is sum of these value of groups. The people of same group's id must be continuous. Now we chose an interval of men and want to know there should be how many groups so the value of interval is max.
 

Input
First line is T indicate the case number. For each case first line is n, m(1<=n ,m<=100000) indicate there are n men and m query. Then a line have n number indicate the ID of men from left to right. Next m line each line has two number L,R(1<=L<=R<=n),mean we want to know the answer of [L,R].
 

Output
For every query output a number indicate there should be how many group so that the sum of value is max.
 

Sample Input
  
  
1 5 2 3 1 2 5 4 1 5 2 4
 

Sample Output
  
  
1 2

题目大概:

连续的数字的个数的平方是给数列的价值,在价值最大的情况下,最长的序列是多少。

思路:

用树状数组,离线一下数据,按照右区间排序,注意的是维护到了第i要看一下前面有没有和它连续的。

这个题是借鉴自其他人的代码思路。

引----

    解题思路:用树状数组离线维护,把询问按照右区间递增排序,然后从1~n维护,维护到i时注意找寻前i个是不是有a[i]-1,和a[i]+1,有的话直接去掉,因为
这两个数必定要和a[i]分到一组,留一个就好了。

代码:


#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=100100;
int n,m,a[maxn],p[maxn],ans[maxn];
struct note
{
    int l,r,id;
    bool operator < (const note &other)const
    {
        return r<other.r;
    }
}que[maxn];

int c[maxn];

int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=c[x];x-=lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            p[a[i]]=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&que[i].l,&que[i].r);
            que[i].id=i;
        }
        sort(que,que+m);
        memset(c,0,sizeof(c));
        int j=0;
        for(int i=1;i<=n;i++)
        {
            add(i,1);
            if(a[i]>1&&p[a[i]-1]<i)add(p[a[i]-1],-1);
            if(a[i]<n&&p[a[i]+1]<i)add(p[a[i]+1],-1);
            while(j<m&&que[j].r==i)
            {
                ans[que[j].id]=sum(que[j].r)-sum(que[j].l-1);
                j++;
            }
        }
        for(int i=0;i<m;i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值