Corn Fields (状态dp)

Farmer John has purchased a lush new rectangular pasture composed of M byN (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0
Sample Output
9
Hint
Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题目大概:

在一个n*m的矩形里种玉米,只能在1的位置种,两个种玉米的地不能挨着。问多少个种玉米的方案。


思路:

数据量小,用状态dp表示每一行的状态。

dp【i】【j】表示 i  行的状态为  j  的情况下的方案数。

代码里有大部分注释


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define mod 100000000
#define ma 14
int dp[ma][1<<ma],st[ma];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(st,0,sizeof(st));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<m;j++)
            {
                int a;
                scanf("%d",&a);
                st[i]|=a<<j;//记录每一行的状态
            }

        }
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=n;i++)//枚举行
        {
            for(int j=0;j<(1<<m);j++)//枚举本行状态
            {
               if((j&st[i])==j&&((j&(j>>1))==0))//条件 :给状态被本行状态包含  该行每个玉米都间隔1以上
               {
                   for(int k=0;k<(1<<m);k++)//枚举上一行状态
                   {
                       if((j&k)==0)//两行的状态没有接触的
                       {
                           dp[i][j]+=dp[i-1][k];
                       }
                   }
               }
            }

        }
        int ans=0;
        for(int i=0;i<(1<<m);i++)
        {
            ans+=dp[n][i];
        }
        printf("%d\n",ans%mod);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值