Survival (状态dp)

The King of Fighter 97 (KOF97) is an electronic game of wrestling type. Once it was fashionable among youths. The game is amused. However, playing by oneself is not as excited as with friends. Getting bored? Maybe you can alter to the survival mode.

In the survival mode, you play as usual, but under quite unfair conditions: you must use your only character to beat all the other characters and Orichi as well (who is the BOSS)!!! How can you do that? We know that usually we will consume some HP of the character to beat one opponent. Although the character will recover some HP after beating one opponent, the amount of HP recovered is affected by the time you used, so it��s possible that the character lose some HP after one round. What��s worse, if the HP of your character is not enough for you to beat your opponent, you lose!

Given the HP of your character you need to consume and the HP your character will recover if you win for every opponent, you are to determine whether you can clear the game.

NOTE:
1. The initial HP of your character is 100.
2. You can challenge your opponents in any order except that Orichi is always the last one.
3. If your HP falls BELOW zero after any fights (before recovery), you will get your mission failed. 4. Your HP should never exceed 100.


Input


There are multiple test cases, which are separated by a blank line. The first line of each test case is a single integer N (1 <= N <= 20), gives the number of opponents you need to beat. The following N �C 1 lines each contain two integers C and R (0 <= C, R <= 100), where C for the HP you need to consume to beat the opponent and R for the HP recovered after you beat the opponent. The last line contains only one integer P (0 <= P <= 100), describing the HP you need to consume to beat Orichi.


<b< dd="">

Output


For each test case, generate one line of output: if you can clear the game, print "clear!!!" otherwise print "try again" (both without quotations).


<b< dd="">

Sample Input


3
50 50
40 40
70


<b< dd="">

Sample Output


clear!!!

题目大概:

你要击败n个敌人,击败每个敌人,需要花费血,并且能够恢复一部分生命值,最后击败boos,不回复生命值,问是否能够把敌人全部击败。


思路:


由于敌人数量比较少,可以用状态dp表示所有敌人的状态。

dp【i】状态为i时 的最大血量值。

代码注释


代码:


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int ma=22;
int dp[1<<ma];
int hua[ma],v[ma];
int end;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)break;

        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d",&hua[i],&v[i]);

        }
        scanf("%d",&end);
        dp[0]=100;

        int cnt=(1<<(n-1));

            for(int j=1;j<cnt;j++)//枚举每一个状态
            {
                dp[j]=-9999;
                for(int r1=0;(1<<r1)<=j;r1++)//枚举到达该状态的时候击败的敌人
                {
                    int tem=1<<r1;
                    if(tem&j&&dp[j-tem]>=hua[r1])//该敌人在这种状态下能被击败,包含在状态里。
                    {
                       int ans=dp[j-tem]-hua[r1]+v[r1];
                       if(ans>100)ans=100;
                       if(ans>dp[j])dp[j]=ans;

                    }

                }
            }
            if(dp[cnt-1]>=end)
            printf("clear!!!\n");
            else printf("try again\n");
    }


    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值