Most Powerful (状态dp)

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

<b< dd="">

Output

Output the maximal power these N atoms can produce in a line for each case.

<b< dd="">

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

<b< dd="">

Sample Output

4
22


题目大概:

有n个原子,给出原子i和j碰撞后j原子迸发的能量,求最大的能量和。


思路:

把所有的原子压缩成一个数。

dp【i】状态为i时的最大能量和

方程  dp[i|tmp1]=max(dp[i|tmp1],dp[i]+mp[k][j])

代码注释

代码:


#include<cstdio>
#include<iostream>
#include<cstring>
#define maxn (1<<10)
using namespace std;

int dp[maxn],mp[15][15];


int main()
{
    int n,tot,ans;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d",&mp[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        tot=(1<<10);
        for(int i=0;i<tot;i++)//枚举每个状态
        {
            for(int j=0;j<n;j++)//枚举爆发能量的原子
            {
                int tmp1=(1<<j);
                if((i&tmp1)==0)//该原子要不包含在状态里
                {
                    for(int k=0;k<n;k++)//枚举和它碰撞的原子
                    {
                        int tmp2=(1<<k);
                        if((i&tmp2)==0 && j!=k)//同样不包含
                            dp[i|tmp1]=max(dp[i|tmp1],dp[i]+mp[k][j]);//转移方程,
                    }
                }
            }
        }
        ans=0;
        for(int i=0;i<tot;i++)
        {
            if(dp[i]>ans)
                ans=dp[i];
        }
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值