#1458 : Parentheses Matching

描述

Given a string of balanced parentheses output all the matching pairs.

输入

A string consisting of only parentheses '(' and ')'. The parentheses are balanced and the length of the string is no more than 100000.

输出

For each pair of matched parentheses output their positions in the string.

样例输入
(())()()
样例输出
1 4  
2 3  
5 6  
7 8

一般括号匹配的变形,错了一发,要把所有情况想清楚再写。


代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn=110000;
int a[maxn],b[maxn];
int d[maxn];
int v[maxn];
int main()
{
    char c[maxn];
    scanf("%s",c);
    int l=strlen(c);
    int ans1=0,ans2=0;
    int tem=0;
    for(int i=0;i<l;i++)
    {
        if(c[i]=='(')
        {
            a[ans1++]=i+1;
            tem=ans1-1;
        }
        else
        {
            b[ans2++]=i+1;
            while(v[tem])
            {
                tem--;
            }
            d[tem--]=ans2-1;
            v[tem+1]=1;
        }
    }
    for(int i=0;i<ans1;i++)
    {
        printf("%d %d\n",a[i],b[d[i]]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值