Parentheses Matching(栈)

题目1 : Parentheses Matching

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Given a string of balanced parentheses output all the matching pairs.

输入

A string consisting of only parentheses '(' and ')'. The parentheses are balanced and the length of the string is no more than 100000.

输出

For each pair of matched parentheses output their positions in the string.

样例输入
(())()()
样例输出
1 4  
2 3  
5 6  
7 8
这道题给了我栈的另外一种用法,原来配对括号的时候,栈还可以压入它的下标,最后排下序就好了。
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<stack>
using namespace std;
char s[100005];
struct A
{
    int q,p;
}a[50005];
bool cmp(A m,A n)
{
    return m.q<n.q;
}
int main()
{
    gets(s);
    int len=strlen(s);
    stack <int>t;
    int l=0;
    for(int i=0;i<len;i++)
    {
        if(s[i]=='(')
            t.push(i+1);
        else
        {
            a[l].q=t.top();
            a[l].p=i+1;
            t.pop();
            l++;
        }
    }
    sort(a,a+l,cmp);
    for(int i=0;i<l;i++)
    {
        printf("%d %d\n",a[i].q,a[i].p);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值