Taekwondo(dp)

Taekwondo is the name of a traditional Korean martial art and it is turned into a modern international
sport. It is adopted by IOC (International Olympic Committee) as an official game of 2000 Sydney
Olympic Games. In Taekwondo, there are individual competitions and team competitions. An individual
competition is conducted by two players and a team competition is a set of individual competitions.
For two groups of players, we are going to make a team competition where two players for each individual
competition are selected from each group. Note that players in each group can participate at most
one individual competition. For fair competition, weights of two players in each individual competition
must be very close. Given weights of players in two groups, you are to write a program to find pairs of
players so that the sum of the absolute differences of theweights of two players in each competition is
minimized.
Input
The input file consists of several test cases. The first line of the input file contains an integer representing
the number of test cases. The first line of each test case contains two integers. The first integer, n1,
is the number of players in the first group, and the second integer, n2, is the number of players in the
second group, where 1 ≤ n1, n2 ≤ 500. You have to make min{n1, n2} pairs of players. Each line of
the next n1 lines contains the weight of the player in the first group and the next n2 lines contain the
weights of players in the second group. Weights of players are in the range of 40.0 to 130.0. You may
assume that the precision of weight is one tenth.
Output
For each test case, your program reports the minimum of the sum of the absolute differences of the
weights of two players in each individual competition in the team competition.
Sample Input
2
2 3
44.9
50.0
77.2
86.4
59.8
4 2
44.9
50.0
77.2
86.4
59.8
58.9
Sample Output
42.1

23.8

题目大概:

就是给出了两组数 n个  m个 ,要求全部配对,使得所有  配对的数 的  abs(a【i】-b【j】)之和最小。

思路:

可以排序下,再dp。

dp【i】【j】代表,匹配了i对,到了第j个的时候的最小值。

那么,就需要把最短的那组数放到前面,这样才能符合这个dp定义,不会出错。

然后,由于我们已经排好序。所以这两组数之间所在区间范围,要么相离,要么相交。相交的话,那么匹配第i对数的时候,i前面的数b【j】是比 a【i】小的话,一顶定会找i 前面的数进行匹配,因为如果是找i,会出现交叉,一定不是最小的,可以画一下试试,如果匹配第i对数的时候,i前面的数b【j】是比 a【i】大的话,那么这一段是相离的,无论怎么匹配都是一样的结果,所以,我们可以让匹配到i对的时候,总是从第i个之后的b【j】和它匹配。

即匹配第一组第i个数时,要么是不匹配。要么是和第二组i之后的数匹配(包括i)。

代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn=510;
double a[maxn],b[maxn];
double dp[maxn][maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf",&a[i]);
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%lf",&b[i]);
        }
        if(n>m)
        {
            for(int i=1;i<=n;i++)
            {
                double p=a[i];
                a[i]=b[i];
                b[i]=p;
            }
            int p=n;
            n=m;
            m=p;
        }
        sort(a+1,a+n+1);
        sort(b+1,b+m+1);
        dp[1][1]=fabs(a[1]-b[1]);
        for(int i=2;i<=m;i++)
        {
            dp[1][i]=min(dp[1][i-1],fabs(a[1]-b[i]));
        }
        for(int i=2;i<=n;i++)
        {
            dp[i][i]=dp[i-1][i-1]+fabs(a[i]-b[i]);
            for(int j=i+1;j<=m;j++)
            {
                dp[i][j]=min(dp[i][j-1],dp[i-1][j-1]+fabs(a[i]-b[j]));
            }
        }
        printf("%.1lf\n",dp[n][m]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值