Taekwondo

最近做简单dp越来越有感觉了。(不过思路依然不是自己想出来的)

这道题题意就是给定两组数字,然后凑成组数较少的那个组数,要求每一组的绝对值的总和最少。

思路就是贪心。因为两组数(一组是组数小的n,一组是组数大的m),由小到大排个序,然后依次枚举。一定要排序。

用dp[i][j]表示搜到第i组了, 组数较大的序列中第j个时最小的dp值。

注意细节。fabs用来double绝对值。

最后输出保留一位小数

题目:

Taekwondo is the name of a traditional Korean martial art and it is turned into a modern international
sport. It is adopted by IOC (International Olympic Committee) as an official game of 2000 Sydney
Olympic Games. In Taekwondo, there are individual competitions and team competitions. An individ-
ual competition is conducted by two players and a team competition is a set of individual competitions.
For two groups of players, we are going to make a team competition where two players for each individ-
ual competition are selected from each group. Note that players in each group can participate at most
one individual competition. For fair competition, weights of two players in each individual competition
must be very close. Given weights of players in two groups, you are to write a program to find pairs of
players so that the sum of the absolute differences of theweights of two players in each competition is
minimized.
Input
The input file consists of several test cases. The first line of the input file contains an integer representing
the number of test cases. The first line of each test case contains two integers. The first integer,
n
1
,
is the number of players in the first group, and the second integer,
n
2
, is the number of players in the
second group, where
1

n
1
,
n
2

500
. You have to make min
f
n
1
;n
2
g
pairs of players. Each line of
the next
n
1
lines contains the weight of the player in the first group and the next
n
2
lines contain the
weights of players in the second group. Weights of players are in the range of 40.0 to 130.0. You may
assume that the precision of weight is one tenth.
Output
For each test case, your program reports the minimum of the sum of the absolute differences of the
weights of two players in each individual competition in the team competition.
Sample Input
2
2  3
44.9
50.0
77.2
86.4
59.8
4  2
44.9
50.0
77.2
86.4
59.8
58.9
Sample Output
42.1
23.8

具体见代码:

#include<bits/stdc++.h>
using namespace std;
double a[510],b[510],dp[510][510];
int main()
{
    int t;
    int n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            scanf("%lf",&a[i]);
        }
        for(int i=1;i<=m;i++){
            scanf("%lf",&b[i]);
        }
        if(n>m){
            swap(n,m);
            swap(a,b);
        }
        sort(a+1,a+1+n);
        sort(b+1,b+1+m);
        dp[0][0]=0;
        for(int i=1;i<=n;i++){
                dp[i][i]=dp[i-1][i-1]+fabs(b[i]-a[i]);//类似于初始化
            for(int j=i+1;j<=m;j++){//依次向后找进行配
                dp[i][j]=min(dp[i-1][j-1]+fabs(a[i]-b[j]),dp[i][j-1]);//要么配j,要么不配j
            }
        }
        printf("%.1lf\n",dp[n][m]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值