POJ 1703 Find them, Catch them (数据结构-并查集)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31102 Accepted: 9583

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


题目大意:

T组测试数据,n个人,m组询问,D a b 表示 a,b 不在同一个gang(虽然不知道gang是什么意思?) ,A a b表示a和b的关系。


解题思路:

只需要并查集,再加入一个enemy数组记录某人的一个敌人即可。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=110000;
int father[maxn],enemy[maxn],n,m;

int find(int x){
    if(father[x]!=x){
        father[x]=find(father[x]);
    }
    return father[x];
}

void combine(int x,int y){
    int a=find(x),b=find(y);
    father[b]=a;
}

void solve(){
    char ch;
    int a,b;
    while(m-- >0){
        getchar();
        scanf("%c%d%d",&ch,&a,&b);
        //cout<<ch<<"->"<<a<<"->"<<b<<endl;
        if(ch=='D'){
            if(enemy[a]!=-1) combine(enemy[a],b);
            if(enemy[b]!=-1) combine(enemy[b],a);
            enemy[a]=b;
            enemy[b]=a;
        }else{
            if(enemy[a]==-1 || enemy[b]==-1 )  printf("Not sure yet.\n");
            else{
                if(find(a)==find(b)) printf("In the same gang.\n");
                else if(find(enemy[a])==find(b) || find(a)==find(enemy[b]) ) printf("In different gangs.\n");
                else printf("Not sure yet.\n");
            }
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t-- >0){
        scanf("%d%d",&n,&m);
        for(int i=0;i<=n;i++){
            father[i]=i;
            enemy[i]=-1;
        }
        solve();
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

炒饭君

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值