POJ 1703-Find them, Catch them(并查集)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45008 Accepted: 13862

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


题目意思:

一共有俩犯罪团伙,N个人中有人可能是罪犯,D a b表示a和b属于同一个犯罪团伙,A a b表示询问a和b的团伙关系。

解题思路:

反正就俩犯罪团伙,标记set[a]和set[a+n]分别是两个犯罪团伙。
合并时如果不是其中一派,那就是另外一派;查询时如果不是其中一派还可能自成一派。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const long N=100000+5;
int m,n;
int set[N+N];
int set_find(int d)
{
    if(set[d]<0) return d;
    return set[d]=set_find(set[d]);
}
void unite(int p,int q)
{
    p=set_find(p);
    q=set_find(q);
    if(p!=q) set[p]=q;
}
int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(set,-1,sizeof(set));//初始化时各成一派
        for(i=0; i<m; ++i)
        {
            int a,b;
            char s[5];
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='A')//询问
            {
                if(set_find(a)!=set_find(b)&&set_find(a)!=set_find(b+n))
                    printf("%s\n","Not sure yet.");
                else if(set_find(a)==set_find(b))
                    printf("%s\n","In the same gang.");
                else
                    printf("%s\n","In different gangs.");
            }
            else//合并
            {
                unite(a,b+n);
                unite(b,a+n);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值