vue基础:To install it, you can run: npm install --save,写 scss样式报错

vue 专栏收录该内容
20 篇文章 0 订阅

vue基础:To install it, you can run: npm install --save,写 scss样式报错

最近在学习vue时一个报错,困扰了小谷好久。
报错代码:

This dependency was not found:

* !!vue-style-loader!css-loader?{"sourceMap":true}!../../node_modules/vue-loader/lib/style-compiler/index?{"vue":true,"id":"data-v-8dc7cce2","scoped":false,"hasInlineConfig":false}!sass-loader?{"sourceMap":true}!../../node_modules/vue-loader/lib/selector?type=styles&index=0!./Home.vue in ./src/components/Home.vueTo install it, you can run: npm install --save !!vue-style-loader!css-loader?{"sourceMap":true}!../../node_modules/vue-loader/lib/style-compiler/index?{"vue":true,"id":"data-v-8dc7cce2","scoped":false,"hasInlineConfig":false}!sass-loader?{"sourceMap":true}!../../node_modules/vue-loader/lib/selector?type=styles&index=0!./Home.vue

查询了很多人没有看到解决的方法,后来无意中发现是scss样式报错。
在这里插入图片描述
解决方法
删除<style lang="scss">中的lang="scss,因为是新手,所以发现果然可以。后来查阅了资料。
安装以下依赖就可以了,vue-cli默认没有scss-loader,scss-loader又需要node-sass,只安装scss-loader是不行的。另外webpack就不需要配置了,因为vue-cli会帮你配置安装的loader

"node-sass": "^4.5.1",
    "sass-loader": "^6.0.3",
    "scss": "^0.2.4",
    "scss-loader": "^0.0.1",

npm install node-sass --save
npm install sass-loader --save
npm install scss --save
npm install scss-loader --save

©️2021 CSDN 皮肤主题: 终极编程指南 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值