Java实现 蓝桥杯 算法训练 寻找数组中最大值

算法训练 寻找数组中最大值
时间限制:1.0s 内存限制:512.0MB
提交此题
问题描述
  对于给定整数数组a[],寻找其中最大值,并返回下标。
输入格式
  整数数组a[],数组元素个数小于1等于100。输出数据分作两行:第一行只有一个数,表示数组元素个数;第二行为数组的各个元素。
输出格式
  输出最大值,及其下标
样例输入
3
3 2 1

样例输出

3 0

import java.util.Scanner;


public class 寻找数组中的最大值 {
	public static void main(String[] args) {
		Scanner sc =new Scanner(System.in);
		int n = sc.nextInt();
		int [] num = new int [n];
		int max = Integer.MIN_VALUE;
		int count = 0;
		for (int i = 0; i < num.length; i++) {
			num[i]=sc.nextInt();
			if (max<num[i]) {
				max = num[i];
				count=i;
			}
			
		}
		System.out.println(max);
		System.out.println(count);
	}

}

  • 23
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 25
    评论
评论 25
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值