(模板题)poj 2524 Ubiquitous Religions(并查集)

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 31596 Accepted: 15314

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

提示

题意:

在全球各地有各式各样的宗教,它们之间相互影响,从而你对大学生有多少个不同的宗教信仰产生了兴趣。

你知道你的大学有n个学生(0<n<=50000)。你直接上去问他们信仰什么宗教显然是不礼貌的。那么有一种方式可以避免此类问题,去询问m(0<=m<=n(n-1)/2)对学生是否信仰同一个宗教。有这些数据,你可能不知道每个人信仰什么宗教,但你却可以知道学校里有多少个不同的宗教信仰。我们假设一个学生只能信仰一个宗教。

那么问题来了,请输出有几个不同的宗教。

思路:

做过sdut数据结构的同学对这题不会很陌生。

示例程序

Source Code

Problem: 2524		Code Length: 723B
Memory: 556K		Time: 422MS
Language: GCC		Result: Accepted
#include <stdio.h>
int main()
{
    int num,n,m,a[50000],i,i1,x,y;
    scanf("%d %d",&n,&m);
    for(i=1;n!=0||m!=0;i++)
    {
        num=0;
        for(i1=0;n>i1;i1++)
        {
            a[i1]=i1;
        }
        for(i1=1;m>=i1;i1++)
        {
            scanf("%d %d",&x,&y);
            x--;
            y--;
            while(x!=a[x])
            {
                x=a[x];
            }
            while(y!=a[y])
            {
                y=a[y];
            }
            a[y]=x;
        }
        for(i1=0;n>i1;i1++)
        {
            if(a[i1]==i1)
            {
                num++;
            }
        }
        printf("Case %d: %d\n",i,num);
        scanf("%d %d",&n,&m);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值