poj 1035 Spell checker

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24407 Accepted: 8905

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

提示

题意:

你作为一个开发团队新的拼写检查程序的程序员,写的是一个模块,使用一个已知的字典所有正确单词检查给定单词的正确性。
如果在字典中没有这个词,那么它可以被替换为正确的单词(从字典),可以通过以下操作之一:
1.删除一个单词的一个字母;
2.用任意一个字母替换单词中的一个字母;
3.将一个任意字母插入单词。
你的任务是写程序,将从字典中找到所有可能的替换词。

思路:

暴力。

示例程序

Source Code

Problem: 1035		Code Length: 1698B
Memory: 596K		Time: 266MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int main()
{
    int i,i1,i2,num,k,len[10001],l,id[10000],top=0;
    char di[10001][16],ch[16];
    di[0][0]='!';
    for(i=0;i==0||di[i-1][0]!='#';i++)
    {
        scanf("%s",di[i]);
        len[i]=strlen(di[i])-1;				//记录字典每个单词长度
    }
    num=i-1;			//字典中单词数量
    while(1)
    {
        memset(id,-1,sizeof(id));
        top=0;
        scanf("%s",ch);
        if(ch[0]=='#')
        {
            break;
        }
        for(i1=0;num>i1;i1++)
        {
            if(strcmp(ch,di[i1])==0)			//如有完全一致的,直接输出
            {
                printf("%s is correct\n",ch);
                break;
            }
            k=strlen(ch)-1;
            l=len[i1];
            i2=0;				
            while(k>=0&&l>=0&&abs(k-l)<=1)			//差距太大就不可能去修正
            {
               if(ch[k]!=di[i1][l])
               {
                   if(i2==1)			//是否已经忽略一个错误,这里表示可以进行修正来达到与字典的单词完全吻合
                   {
                       break;
                   }
                   if(k>l)			//这里是删除一个字符
                   {
                       k--;
                   }
                   else if(l>k)			//这里是添一个字符
                   {
                       l--;
                   }
                   else				//这里是改变一个字符
                   {
                       l--;
                       k--;
                   }
                   i2=1;
               }
               else
               {
                   l--;
                   k--;
               }
            }
            if(k+l<=-1)			//记录相似单词
            {
                id[top]=i1;
                top++;
            }
        }
        if(i1==num)
        {
            printf("%s:",ch);
            for(i1=0;top>i1;i1++)
            {
                printf(" %s",di[id[i1]]);
            }
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值