Truck History
Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.
Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input 4 aaaaaaa baaaaaa abaaaaa aabaaaa 0 Sample Output The highest possible quality is 1/3. Source |
提示
题意:
给你几串字符,求出它们间距离总和最短。字符串的距离是这样算的,字符串的字符两两依次比较,有一次不同则它两距离加1。(英语不是太好差不多就这样了,并且还是百度来的)
思路:
把距离看做边,这样最小生成树就可以写了。(n比较大应该用邻接表写的,懒了)
示例程序
Source Code
Problem: 1789 Code Length: 1314B
Memory: 15744K Time: 532MS
Language: GCC Result: Accepted
#include <stdio.h>
#include <string.h>
#define MAX 1000000007
int map[2000][2000];
int prim(int n)
{
int d[2000],v[2000],i,i1,t,sum=0,k;
memset(v,0,sizeof(v));
for(i=0;n>i;i++)
{
d[i]=MAX;
}
d[0]=0;
for(i=0;n>i;i++)
{
t=MAX;
for(i1=0;n>i1;i1++)
{
if(v[i1]==0&&t>d[i1])
{
k=i1;
t=d[i1];
}
}
sum=sum+t;
v[k]=1;
for(i1=0;n>i1;i1++)
{
if(v[i1]==0&&d[i1]>map[k][i1])
{
d[i1]=map[k][i1];
}
}
}
return sum;
}
int main()
{
char ch[2000][8];
int n,i,i1,i2,i3,num;
scanf("%d",&n);
for(i=1;n!=0;i++)
{
for(i1=0;n>i1;i1++)
{
scanf("%s",ch[i1]);
}
for(i1=0;n>i1;i1++) //字符串比较
{
for(i2=0;n>i2;i2++)
{
num=0;
for(i3=0;ch[i2][i3]!='\0';i3++)
{
if(ch[i1][i3]!=ch[i2][i3])
{
num++;
}
}
map[i1][i2]=num;
}
}
printf("The highest possible quality is 1/%d.\n",prim(n));
scanf("%d",&n);
}
return 0;
}