poj 1258 Agri-Net

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51418 Accepted: 21436

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

提示

题意:

农夫约翰成功被选为镇长!他的竞选承诺之一是给该地区所有的农场带来互联网连接。当然,他需要你的帮助。
农夫约翰为他的农场订制了一个高速宽带连接,并将分享给其他农民。为了最大限度地降低成本,他想铺设最小数量的光纤覆盖到所有其他的农场。
给出一个连接每一对农场需要多少光纤的数据,你必须找到连接它们最少的铺设成本。每个农场都必须连接到其他的农场,这样数据就可以从任何一个农场传到其他农场。
任何两个农场之间的距离将不超过100000。

思路:

喜闻乐见的最小生成树。

示例程序

Source Code

Problem: 1258		Code Length: 876B
Memory: 400K		Time: 32MS
Language: GCC		Result: Accepted
#include <stdio.h>
#define MAX 1000000007
int map[100][100];
int prim(int n)
{
    int v[100],d[100],i,i1,t,k,sum=0;
    for(i=0;n>i;i++)
    {
        d[i]=MAX;
        v[i]=0;
    }
    d[0]=0;
    for(i=0;n>i;i++)
    {
        t=MAX;
        for(i1=0;n>i1;i1++)
        {
            if(v[i1]==0&&t>d[i1])
            {
                t=d[i1];
                k=i1;
            }
        }
        sum=sum+t;
        v[k]=1;
        for(i1=0;n>i1;i1++)
        {
            if(v[i1]==0&&d[i1]>map[k][i1])
            {
                d[i1]=map[k][i1];
            }
        }
    }
    return sum;
}
int main()
{
    int i,n,i1,i2;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;n>i;i++)
        {
            for(i1=0;n>i1;i1++)
            {
                scanf("%d",&map[i][i1]);
            }
        }
        printf("%d\n",prim(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值