poj 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38228 Accepted: 10013

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

提示

题意:
你可能听说过,没有两个雪花是一样的。你的任务是写一个程序,以确定是否这是真的。您的程序将读取关于一个雪花的信息,并搜索一对是否相同的。每片雪花有六个角(就这样称呼吧)。对于每一个雪花,将提供六个角的长度。只要数值相同,不管顺序,相同就输出“Twin snowflakes found.”,不同输出“No two snowflakes are alike.”。
思路:
我用的是除留余数法+线性探测法(也不知道是不是),对于不管顺序,存入数据时排序就行了。(空间复杂度和时间复杂度还是挺高的)

示例程序

Source Code

Problem: 3349		Code Length: 1119B
Memory: 27808K		Time: 2344MS
Language: G++		Result: Accepted
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct num
{
    int d[6],bug;				//bug用来表示该位置有没有数据占用
}ha[10000][100];
int judge(int t,int pos,int a[])
{
    int i;
    for(i=0;6>i;i++)
    {
        if(ha[t][pos].d[i]!=a[i])
        {
            return 0;
        }
    }
    return 1;
}
int main()
{
    int n,i,i1,i2,sum,a[6];
    memset(ha,0,sizeof(ha));			//初始化一下,方便存数据
    scanf("%d",&n);
    for(i=1;n>=i;i++)
    {
        sum=0;
        for(i1=0;6>i1;i1++)
        {
            scanf("%d",&a[i1]);
            sum=(sum+a[i1])%10000;
        }
        sort(a,a+6);				//一来就排序能少很多的麻烦
        if(i2==-1)				//有相同的后面就不管了
        {
            continue;
        }
        for(i2=0;ha[sum][i2].bug!=0;i2++)
        {
            if(judge(sum,i2,a)==1)
            {
                i2=-1;				//标记是否有相同的
                break;
            }
        }
        if(i2==-1)
        {
            printf("Twin snowflakes found.");
            continue;
        }
        for(i1=0;6>i1;i1++)
        {
            ha[sum][i2].d[i1]=a[i1];
            ha[sum][i2].bug=1;
        }
    }
    if(i2!=-1)
    {
        printf("No two snowflakes are alike.");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值