poj 1276 Cash Machine

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32795 Accepted: 11881

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

提示

题意:

我们有n(0<=n<=10)种面值的货币,给出一个数,看能不能在这些货币中选出最接近这个数。比如样例一这个数是735,我们选出3个125的,2个5的,一个350的,那么3*125+2*5+350=735,这个最接近735。要注意,最接近的范围是小于等于这个数,超出不算。

思路:

这是多重背包问题,

递推式:dp[j]=MAX(dp[j],dp[j-v[i]]+v[i]),dpnum[j]=dpnum[j-v[i]]+1,要判断一下该种货币有没有拿完,dp为价值的状态记录,dpnum为货币所拿数量的状态记录。

不懂的还是来点野生链接君

示例程序

这里给出的是链接里的做法:
Source Code

Problem: 1276		Code Length: 895B
Memory: 1136K		Time: 16MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int num,vi;
}q[10];
int main()
{
    int cash,n,i,dp[100001],dpnum[100001],i1,i2;
    while(scanf("%d",&cash)!=EOF)
    {
        scanf("%d",&n);
        for(i=0;n>i;i++)
        {
            scanf("%d %d",&q[i].num,&q[i].vi);
        }
        memset(dp,0,sizeof(dp));
        if(cash==0)
        {
            printf("0\n");
        }
        else
        {
            for(i=0;n>i;i++)
            {
                memset(dpnum,0,sizeof(dpnum));			//因为枚举每种货币,所以计数器要清0
                for(i1=q[i].vi;cash>=i1;i1++)
                {
                    if(dp[i1]<dp[i1-q[i].vi]+q[i].vi&&dpnum[i1-q[i].vi]<q[i].num)	//递推式执行的条件判断,后面那一条是保证执行前还有该种货币
                    {
                        dp[i1]=dp[i1-q[i].vi]+q[i].vi;
                        dpnum[i1]=dpnum[i1-q[i].vi]+1;
                    }
                }
            }
            printf("%d\n",dp[cash]);
        }
    }
    return 0;
}
这给出的是讨论区里的做法(不太明白):

Source Code

Problem: 1276		Code Length: 1402B
Memory: 1140K		Time: 0MS
Language: G++		Result: Accepted
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct money
{
    int num,vi;
}q[10];
int cmp(struct money a,struct money b)
{
    if(a.vi<b.vi)
    {
        return 1;
    }
    else
    {
        return 0;
    }
}
int main()
{
    int cash,n,i,dp[100001],dpnum[100001],i1,i2;
    while(scanf("%d",&cash)!=EOF)
    {
        scanf("%d",&n);
        for(i=0;n>i;i++)
        {
            scanf("%d %d",&q[i].num,&q[i].vi);
        }
        sort(q,q+n,cmp);					//排序
        memset(dp,0,sizeof(dp));					//数据初始化
        memset(dpnum,0,sizeof(dpnum));
        dp[cash]=1;						//倒着来
        dpnum[cash]=q[0].num;
        if(cash==0)
        {
            printf("0\n");
        }
        else
        {
            for(i=0;n>i;i++)
            {
                for(i1=cash;q[i].vi<=i1;i1--)			//这也是反的
                {
                    if(dp[i1]!=0)
                    {
                        if(dpnum[i1]!=0&&dp[i1-q[i].vi]==0)			//执行条件
                        {
                            dpnum[i1-q[i].vi]=dpnum[i1]-1;
                            dp[i1-q[i].vi]=1;					//因为价值和体积一样,直接标记是否存在
                        }
                        dpnum[i1]=q[i+1].num;
                    }
                }
            }
            for(i=0;cash>=i;i++)
            {
                if(dp[i]==1)
                {
                    printf("%d\n",cash-i);
                    break;
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值