poj 1836 Alignment

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15913 Accepted: 5195

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source

提示

题意:

一位长官想让士兵们站成新的一排,身高以最高的为基准,每个人的身高从左到右是递减,从右到左也是递减,类似于正态分布(个子最高的不一定在最中间):


问至少要几个人出队才能使这一排达到要求?

思路:

左边的身高是从小到大递增,右边是从大到小,那么我们这样想,用DP求出最大上升子序列和最大下降子序列相加,再减去人的数量不就是最少出队的人数么。

求最大上升子序列从队头开始,最大下降子序列从队尾开始,这点要注意一下。

示例程序

Source Code

Problem: 1836		Code Length: 835B
Memory: 396K		Time: 63MS
Language: GCC		Result: Accepted
#include <stdio.h>
int main()
{
    int n,i,i1,dp[2][1000],max=0;		//dp[0][]记录最长递增序列,dp[1][]记录最长递减序列
    double a[1000];
    scanf("%d",&n);
    for(i=0;n>i;i++)
    {
        scanf("%lf",&a[i]);
        dp[0][i]=1;				//最少递增或递减有1个
        dp[1][i]=1;
    }
    for(i=1;n>i;i++)				//从左到右的最长递增序列
    {
        for(i1=0;i>i1;i1++)
        {
            if(a[i]>a[i1]&&dp[0][i1]+1>dp[0][i])
            {
                dp[0][i]=dp[0][i1]+1;
            }
        }
    }
    for(i=n-2;i>=0;i--)				//从右到左的最长递减序列
    {
        for(i1=i+1;n>i1;i1++)
        {
            if(a[i]>a[i1]&&dp[1][i1]+1>dp[1][i])
            {
                dp[1][i]=dp[1][i1]+1;
            }
        }
    }
    for(i=0;i<n;i++)
    {
        for(i1=i+1;i1<n;i1++)			//最长递增序列向后一个数寻找最长的递减序列
        {
            if(dp[0][i]+dp[1][i1]>max)
            {
                max=dp[0][i]+dp[1][i1];
            }
        }
    }
    printf("%d",n-max);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值